Some API requests are failing, impacting Parcel and 'Design Studio' within Customer.io

Incident Report for Parcel

Resolved

The engineers have deployed a fix in all regions, Parcel and the Customer.io 'Design Studio' are now fully operational.
Posted Mar 17, 2025 - 22:40 UTC

Identified

The Engineers have identified the issue and are working on a fix.
Posted Mar 17, 2025 - 22:01 UTC
This incident affected: Web Application & APIs.